Install Node.js

This topic applies to

Applies to

SuiteCommerce Web Stores

Node.js is the platform required for all Gulp.js tasks required to develop any SuiteCommerce site. Node.js is available at:

https://nodejs.org/en/download/

Install the version of Node.js that is supported by your implementation according to the table below. Use the most current minor release (designated by x in the table below) for the version of Node.js you are using.

SuiteCommerce Implementation

Supported Node.js Versions

SuiteCommerce

8.11.4

SuiteCommerce Advanced — 2018.2

8.11.4

SuiteCommerce Advanced — Aconcagua

8.9.x LTS

SuiteCommerce Advanced — Kilimanjaro

6.11.x

SuiteCommerce Advanced — Elbrus

4.x.x LTS and Later

SuiteCommerce Advanced — Vinson

4.x.x LTS

SuiteCommerce Advanced — Mont Blanc

4.4.x and 0.12.x

SuiteCommerce Advanced — Denali

0.12.x

When installing Node.js, ensure that you install all Node.js components. This includes the Node Package Manager (NPM), which is used to install Gulp.js and other files required by the developer tools and the SuiteCommerce build process.

After running the installer, you should see Node.js in the list of available programs on your system. The npm command should also be added to the path on your system.

Note

Ensure that you use the correct installer for your platform. You may have to restart your machine for the Node.js commands to be recognized in the path variable on your system.


To verify that Node.js is installed correctly:

  1. Depending on your platform open a command line or terminal window.

  2. Enter the following command:

    node -v

If everything is installed correctly, this command outputs the currently installed version of Node.js. There should be no errors or warnings.

After successfully installing Node.js, you are ready to Install Gulp.js.